PRISMAservice 2.4.2 release

Scheduled for Sep 16, 06:00 - 07:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 30, 2026 - 08:08 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 30, 2026 - 08:07 UTC

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Jul 30, 2026 - 08:04 UTC
This scheduled maintenance affects: PRISMAservice (Software availability, Advanced Technical views availability, Remote assistance availability, Warranty information and claims availability, Software backend availability, Device search availability, Maintenance Scheduler availability, Meter readings availability, Device status capabilities availability, Device data request availability, Device events availability, Device licenses availability, Mailing system availability).