Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 29, 2026 - 06:01 UTC
Scheduled
Scheduled maintenance for releasing new version
Posted Jul 23, 2026 - 08:53 UTC
This scheduled maintenance affected: PRISMAlytics Dashboard (Software availability, Export to API or CSV functionality, Data processing) and PRISMAlytics Accounting (Software availability).